using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[(\s*[0-9]+\s*),(\s*[0-9]+\s*)\]\s*(>=|<=|==|>|<)\s*([0-9]+)\s*(\|\||\&\&)*";
string input = @"[1,2]==3 || [1,110] >= 2 && [1,200] > 3";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}