$re = '/\d+:\d+ (?i)(?:[ap]m) - \d+:\d+ (?i)(?:[ap]m)/m';
$str = 'Mon-Thu, Sun 11:30 am - 10:00 pm \\\\/ Fri-Sat 11:30 am - 10:30 pm
Mon-Thu, Sun 11:30 AM - 10:00 PM \\\\/ Fri-Sat 11:30 AM - 10:30 PM';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);