# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<iframe.+?src=".*?)(?=:)/\1/g;t' <<< "<p>Some random text <iframe width=\"425\" src=\"http://some-random-link.com\" height=\"350\" frameborder=\"0\"></iframe></p>"