#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(<iframe.+?src=".*?)(?=:)"
Local $sString = "<p>Some random text <iframe width="425" src="http://some-random-link.com" height="350" frameborder="0"></iframe></p>"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)