use strict;
my $str = '<p>Some random text <iframe width="425" src="http://some-random-link.com" height="350" frameborder="0"></iframe></p>';
my $regex = qr/(<iframe.+?src=".*?)(?=:)/p;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";