#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:from\s+(\w+)(?:\.\w+)?\s+)?import\s+([^\s,.]+)(?:\.\w+)?"
Local $sString = "import numpy as np" & @CRLF & _
"import pandas as pd" & @CRLF & _
"import pkg.mod1, pkg.mod2" & @CRLF & _
"from pkg.mod2 import Bar as Qux" & @CRLF & _
"from abc.lmn import pqr" & @CRLF & _
"from abc.lmn import pqr as xyz" & @CRLF & _
"import mod" & @CRLF & _
"from mod import s, foo" & @CRLF & _
"from mod import *" & @CRLF & _
"from pkg.mod3 import *" & @CRLF & _
"from mod import s as string, a as alist" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")