use strict;
my $str = 'import numpy as np
import pandas as pd
import pkg.mod1, pkg.mod2
from pkg.mod2 import Bar as Qux
from abc.lmn import pqr
from abc.lmn import pqr as xyz
import mod
from mod import s, foo
from mod import *
from pkg.mod3 import *
from mod import s as string, a as alist
';
my $regex = qr/^(?:from\s+(\w+)(?:\.\w+)?\s+)?import\s+([^\s,.]+)(?:\.\w+)?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}