# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:from\s+(\w+)(?:\.\w+)?\s+)?import\s+([^\s,.]+)(?:\.\w+)?"
test_str = ("import numpy as np\n"
"import pandas as pd\n"
"import pkg.mod1, pkg.mod2\n"
"from pkg.mod2 import Bar as Qux\n"
"from abc.lmn import pqr\n"
"from abc.lmn import pqr as xyz\n"
"import mod\n"
"from mod import s, foo\n"
"from mod import *\n"
"from pkg.mod3 import *\n"
"from mod import s as string, a as alist\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.