using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(https?)(;.*;?(\b\1\b)(;.*)?|;;)$";
string input = @"http;;http
http;http;
https;;http
http;;https
https;;https
https;https;
http;http;
https;http;
https;https;
http;;
https;;";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}