import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=;charge=)([^-]+?)(?=&lang=en&pt=0&w=)";
final String string = "https://test.com/1.php?h1=987654321&charge=1234567890&lang=en&pt=0&w=\n"
+ "https://test.com/1.php?h1=987654321&charge=1234567890&lang=en&pt=0&w=\n"
+ "https://test.com/1.php?h1=987654321&charge=1234567890&lang=en&pt=0&w=\n"
+ "https://test.com/1.php?h1=987654321&charge=1234567890&lang=en&pt=0&w=\n"
+ "https://test.com/1.php?h1=987654321&charge=1234567890&lang=en&pt=0&w=\n"
+ "https://test.com/1.php?h1=987654321&charge=1234567890&lang=en&pt=0&w=\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}