Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Regular
Expressions
101
Regular
Expressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
(?<=;charge=)([^-]+?)(?=&lang=en&pt=0&w=)
/
m
Test String
New
https://test.com/1.php?h1=987654321&charge=1234567890&lang=en&pt=0&w= https://test.com/1.php?h1=987654321&charge=1234567890&lang=en&pt=0&w= https://test.com/1.php?h1=987654321&charge=1234567890&lang=en&pt=0&w= https://test.com/1.php?h1=987654321&charge=1234567890&lang=en&pt=0&w= https://test.com/1.php?h1=987654321&charge=1234567890&lang=en&pt=0&w= https://test.com/1.php?h1=987654321&charge=1234567890&lang=en&pt=0&w=