re = /^\h*price\h*\|\h*\K.*\S/m
str = 'hello | Hello there
price | Lets talk about our support.
how are you ?| Im fine '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end