using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\^\s*(\w.*)\.";
string input = @"g: x and: y
Transcript show: x; show: y.
^x+y.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}