// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<img[^>]+src="?([^"\s]+)"?\s*"#).unwrap();
let string = "<img alt=\"SOME ALT\" src=\"http://i.imgur.com/UWWQ0Wr.jpg\" title=\"SOME TITLE\">
<img src=\"http://i.imgur.com/1B0mUM2.jpg\" alt=\"SOME ALT\" title=\"SOME TITLE\" />
<img src=\"http://i.imgur.com/UWWQ0Wr.jpg\" alt=\"SOME ALT\" title=\"SOME TITLE\" />";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}