#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\(?([A-Z0-9]{3})\)? \(?([A-Z0-9]{3})\)? \(?([A-Z0-9]{4})\)?"
Local $sString = "8009228080" & @CRLF & _
"" & @CRLF & _
"(900) (CAT) BABA" & @CRLF & _
"" & @CRLF & _
"(+1) (900) (289) (9000)" & @CRLF & _
"" & @CRLF & _
"900.900.9000" & @CRLF & _
"" & @CRLF & _
"(+1) (900) (289) (9000)" & @CRLF & _
"" & @CRLF & _
"(+1) (900) 289 (9000)" & @CRLF & _
"+1 (900) 982 8728"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")