#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "rdstation(?!.*(email|inbound))"
Local $sString = "utmcsr=rdstation|utmccn=curso-intro-coaching|utmcmd=inbound|utmctr=link3" & @CRLF & _
"utmcsr=rdstation|utmccn=agenda-psc|utmcmd=email" & @CRLF & _
"utmcsr=rdstation|utmccn=pnl-porto-alegre"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")