$re = '/\d+(\.(?=\d))?\d*/m';
$str = 'אבג123.אבג
אני קניתי ב2.5~ ש"ח';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;