$re = '/^[A-Z](?:[1-9]|1[0-2])$/m';
$str = 'A1
A2
B3
C4
A23
A12
B22
Z3
Z13
Q11
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);