use strict;
my $str = '\'\'These are the coordinates\'\' :
\'\'Long. 17d. 6′. 8″. lat. 47d. 28′. 8″
\'\'Lon. \'\'36d. 70′. 80″. \'\'lat. 45d. 20′. 5″
\'\'Long. 17d. 6′. 8″.
lat. 47d. 28′. 8″';
my $regex = qr/''Long?(?:'')?\.(?:'')? .*?(?P<Degrees>\d+).*?d.+?(?P<Minutes>\d+)′.*?(?P<Seconds>\d+)″.*?(?:'')?lat(?:'')?\.(?:'')?.*?(?P<Degrees>\d+).*?d.+?(?P<Minutes>\d+)′.*?(?P<Seconds>\d+)″.*?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}