#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=Prize\n)(.+)"
Local $sString = " Invoice" & @CRLF & _
"" & @CRLF & _
"CK DEF Pvt ltd Invoice Number: 14523687" & @CRLF & _
" Account: Karnataka Bank" & @CRLF & _
" Account Number: 42568965113124" & @CRLF & _
"" & @CRLF & _
" Date: 03-08-2021" & @CRLF & _
"" & @CRLF & _
"Company: PRENDON RICARD AUST (WINE) 705328" & @CRLF & _
"Email: Cherrychethan22@gmail.com" & @CRLF & _
"From: Australia PTY LTD" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Store# Name and address of the store" & @CRLF & _
"" & @CRLF & _
"3456 LX WORD SQUARE" & @CRLF & _
" 650 gorge SP" & @CRLF & _
" Bangalore" & @CRLF & _
" 573102" & @CRLF & _
"" & @CRLF & _
"Contact Ph: 2 35 633 125 568" & @CRLF & _
"Purchase order number: 12345678" & @CRLF & _
"Liquor License: LIPQ274013486" & @CRLF & _
"" & @CRLF & _
"Item Description UOM Qty Size Prize" & @CRLF & _
"258947561237 Str huge barrel 7500 ml CARTOM 1 7500 133.15" & @CRLF & _
"986452137954 Str HUGO Chardony 750 ml CARTOM 1 750 11.4" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")