#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[^/]+\.[^.]+$"
Local $sString = "http://www.demo.com/profiles-forum/linda-blair.php" & @CRLF & _
"http://www.demo.com/profiles-forum/linda-blair.txt" & @CRLF & _
"http://www.demo.com/profiles-forum/linda-blair.jpeg" & @CRLF & _
"http://www.demo.com/profiles-forum/linda_blair.php" & @CRLF & _
"http://www.demo.com/profiles-forum/linda.blair.txt" & @CRLF & _
"http://www.demo.com/profiles-forum/lindablair.jpeg"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")