$re = '/<a([^>]+?)href\s*=\s*("|\'|\s?)(.+?)\2(?=\s{1}|>)/';
$str = '<a href=/pesho></a>
<a href=\'Ilia\'></a>
<a class="bull" href="http://super-href/dot.com"></a>
<a href=/softuni.bg class="danger\'></a>
<!DOCTYPE html>
<html>
<head>
<title>Hyperlinks</title>
<link href="theme.css" rel="stylesheet" />
</head>
<body>
<ul><li><a href="/" id="home">Home</a></li><li><a
class="selected" href=/courses>Courses</a>
</li><li><a href =
\'/forum\' >Forum</a></li><li><a class="href"
onclick="go()" href= "#">Forum</a></li>
<li><a id="js" href =
"javascript:alert(\'hi yo\')" class="new">click</a></li>
<li><a id=\'nakov\' href =
http://www.nakov.com class=\'new\'>nak</a></li></ul>
<a href="#empty"></a>
<a id="href">href=\'fake\'<img src=\'http://abv.bg/i.gif\'
alt=\'abv\'/></a><a href="#"><a href=\'hello\'></a>
<!-- This code is commented:
<a href="#commented">commentex hyperlink</a> -->
</body>
END';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);