use strict;
my $str = '<meta name="keywords" content="keyword1, keyword2, keyword3">
<a href="something" onclick= "bad()">text</a> onclick not in tags
<a href="something" onclick =bad()>text</a>
<a href="something" onclick=bad(\'test\')>text</a>
<a href="something" onclick=bad("test")>text</a>
<a href="something" onclick="bad()" >text</a>
<a href="http://mydomain.com/index.php?oninaval=12" class="titi">text</a>
What if I write john+onelia=love forever?
<a href="something" onclick="bad()">text</a> onclick not in tags
<a href="something" onclick=bad()>text</a>
<a href="something" onclick="bad()" >text</a>
<a href="something" onclick=a++ >text</a>
onclick="asd <span class="myclass"> not in tag too.</span>
<!-- onclick=" --><a href="something" onclick= "bad()">text</a>
<textarea><enter onclick="dothat()" text here></textarea>
yoko ono="john lennon"
<img src="/images/img1.jpg" alt="onclick=thegood() onclick=thebad() "/>
<img alt="onclick=" src=/images/theugly.jpg> the most important part of the message <p class="disappears"></p>
<a href="" onmouseover=a=7>button1</a>
<a href="something" onclick=a++>text</a>
<a href="something" onclick=a<<1>text</a>
<a href="" onmouseover="alert(a);">button2</a>';
my $regex = qr/(<.+?)(?<=\s)on[a-z]+\s*=\s*(?:(['"])(?!\2).+?\2|(?:\S+?\(.*?\)(?=[\s>])))(.*?>)/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}