package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[0-9]{4}[A-Z]{4}$`)
var str = `1234ABCD`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}