// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?<variable>[$][a-zA-Z_\x80-\xff][a-zA-Z0-9_\x80-\xff]*)[[](?<index>[^']+?)[\]]").unwrap();
let string = "$row[number]; $row[user];
$row['number']; $row['user'];";
let substitution = "$1['$2']";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}