package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z0-9_]+(?:\.[a-zA-Z0-9_]+)*$`)
var str = `abc
abc.xyz
.abc
abc.
ab..c
abc.xyz.
abc.xyz.1
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}