$re = '/^[a-zA-Z0-9_]+(?:\.[a-zA-Z0-9_]+)*$/m';
$str = 'abc
abc.xyz
.abc
abc.
ab..c
abc.xyz.
abc.xyz.1
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);