re = /filter.........([^"]*)/m
str = '{
"bridge": {
"name": "Homebridge",
"username": "XX:22:3D:XX:CE:31",
"port": 51826,
"pin": "031-45-154"
},
"platforms": [
{
"platform": "FHEM",
"name": "FHEM",
"server": "127.0.0.1",
"port": "8083",
"auth": {"user": "Bernd", "pass": "xxxxx"},
"filter": "room=Homekit"
}
],
"accessories": []
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end