#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\d+(\,\d+)*)x(\d+(\,\d+)*)"
Local $sString = "А можно чуть усложнить задачу, а то у меня к вечеру пятницы мозг замылился :( допустим числа дробные, разделитель - запятая, то есть (цифра или запятая)x(цифра или запятая) ?" & @CRLF & _
"Например: 24,3x100,5"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")