using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\.\d{4}).*";
string input = @"/* Note: input consist digits[0-9] and one dot'.' only, before the match starts. The input on first line and last line is invalid */
2323.34.34.34.34.
45454.454455445
24334.45654565
65.5643423f5623/556
24...34..43436";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}