using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:[cC][hH]|[lL][lL]|[rR][rR]|[qQ][uU]|[mnñvzsyjhxwMNÑVZSYJHXW]|[fpbtdkgcFPBTDKGC][lrLR]?|[lrLR])?(?:[iuüIUÜ][eaoéáóEAOÉÁÓ][iyuIYU]|[aáAÁ][hH]?[uúUÚ][aáAÁ]|[iuüIUÜ][hH]?[eaoéáóEAOÉÁÓ]|[eaoéáóEAOÉÁÓ][hH]?[iyuIYU]|[iíIÍ][hH]?[uúUÚ]|[uúüUÚÜ][hH]?[iíyIÍY]|[ieaouíéáóúüIEAOUÍÉÁÓÚÜ])(?:(?:(?:(?:[nmNM]|[rR](?![rR]))s?(?![ieaouíéáóúüIEAOUÍÉÁÓÚÜ]))|(?:(?:[mnñvzsyjhxwMNÑVZSYJHXW]|[lL](?![lL]))(?![ieaouíéáóúüIEAOUÍÉÁÓÚÜ]))|(?:(?:[fpbtdkgFPBTDKG]|[cC](?![hH]))(?![lrLR]?[ieaouíéáóúüIEAOUÍÉÁÓÚÜ])))(?!\s|$))?(?:[ndrlsxNDRLSX](?=\s|$))?";
string input = @"SÍLABA CV
casado
caro
NÚCLEOS VOCÁLICOS
DIPTONGOS
ai, au, ei, eu, oi, ou, ui, iu, ia, ua, ie, ue, io, uo
varió comió diario miel
CON DOS CERRADAS
distribuido atribuir atribuí
muy fui rey
pausa tierra
ciudad buitre
CON H INTERCALADA
desahuciar, ahijado
TRIPTONGOS
santigüeis
guay guau rey
haliéutica hioides huaico
AUA
palauano
nahuatl cacahuatal
HIATOS NORMATIVOS (DOS CONSONANTES ABIERTAS)
aorta
héroe
almohada
línea
HIATOS
tú sabrías, sabías, vosotros sabíais
raúl oído búho
tío púa
ATAQUE C+LÍQUIDA
cromo
claro
cabra
triple
dígrafos
CODAS
silbo
cansado
tacto
texto
anticiparse
álbumes
asfixia
enloquecer
SUCESIÓN NS MS RS
transportar
transacción
torso
perspectivas
samsara
CODAS A FINAL DE PALABRA
hablan hablar hablad
riel rieles
sílex
recto
DÍGRAFOS
chica
coche
llave
calle
carro
EXTRANJERISMOS
pícnic
hámster
mozzarella
marketing
búnker
sándwich
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}