$re = '/(?P<type>RESERVED)(?:::)(?P<desc>[\w#()/]*)/m';
$str = 'RESERVED::NETWORK_MIGRATION
RESERVED::ASBX_CO_01_MIGRATION';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);