re = /(?P<type>RESERVED)(?:::)(?P<desc>[\w#()\/]*)/m
str = 'RESERVED::NETWORK_MIGRATION
RESERVED::ASBX_CO_01_MIGRATION'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end