const regex = /\d(?!\d{22})(102030)\d{10}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d(?!\\d{22})(102030)\\d{10}', 'g')
const str = `75277887243040354513001
55345377243014107206375
810203087654135168
1102030698798798477
71020307248040361799581`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}