import Foundation
let pattern = #"\d(?!\d{22})(102030)\d{10}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
75277887243040354513001
55345377243014107206375
810203087654135168
1102030698798798477
71020307248040361799581
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)