import re
regex = re.compile(r"^.+?N+(?=[^N]{3})", flags=re.MULTILINE)
test_str = "NNNNNNNNNNNNNGNNACNCNTGCNAGTCGAGCGGATGACGGGAGCTTGCTCCCGGATTCAGCGGCGGACGGGTGAGTAATGCCTAGGAATCTGCCNTGGTAGATCGNATCGATCGATCGNNTNNN"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)