import Foundation
let pattern = #"^.+?N+(?=[^N]{3})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"NNNNNNNNNNNNNGNNACNCNTGCNAGTCGAGCGGATGACGGGAGCTTGCTCCCGGATTCAGCGGCGGACGGGTGAGTAATGCCTAGGAATCTGCCNTGGTAGATCGNATCGATCGATCGNNTNNN"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)