package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:(\?=)|)(?:(?:( |\n|\r\n)|)(?:( |\t)|)|)(?: |)(=)(?:[A-Za-z0-9].*|)(\?(UTF|utf)\-8\?)([A-Za-z0-9]\?)`)
var str = `?=
=?UTF-8?Q?
?=
=?UTF-8?Q?
=3D?UTF-8?Q?
=3D?UTF-8?Q?
=?UTF-8?Q?
=?UTF-8?Q?
?= =?UTF-8?Q?`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}