const regex = new RegExp('(?:(\\?=)|)(?:(?:( |\\n|\\r\\n)|)(?:( |\\t)|)|)(?: |)(=)(?:[A-Za-z0-9].*|)(\\?(UTF|utf)\\-8\\?)([A-Za-z0-9]\\?)', 'gm')
const str = `?=
=?UTF-8?Q?
?=
=?UTF-8?Q?
=3D?UTF-8?Q?
=3D?UTF-8?Q?
=?UTF-8?Q?
=?UTF-8?Q?
?= =?UTF-8?Q?`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}