$re = '/[a-zA-Z]{0,4}X/m';
$str = 'abXdef
abcdX
aXcdXf
aXXXX';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);