re = /"key"\s*:\s*"\$\$([^$]*)\$\$"/m
str = '{ parameters: { "key" : "$$value$$" } }
{parameters:{ "key":"$$value$$" } }
{parameters:{ "key":"$$value$$" } }'
subst = '"key":"$($1)"'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result