re = /(domain1|domain2|domain3).(com|net|org|com\.au) Final Notice/i
str = 'Domain1.com Final Notice'
# Print the match result
str.match(re) do |match|
puts match.to_s
end