Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
customer name is ([\w\s]*?(?=(?:and|or|$)))?(?:(?:(?:and|or) customer id is )(\d*)|c)? ?(?:(?:(?:and|or) policy id is ([a-zA-Z0-9]*)))?
/
gm
Input 1
1
New
customer name is jason estibeiro and customer id is 1234532 customer name is jason estibeiro or customer id is 1234532 customer name is sajal sharma and customer id is 1234532 and policy id is abcd1234 customer name is sajal sharma and customer id is 1234532 or policy id is abcd1234 customer name is sajal sharma or customer id is 1234532 and policy id is abcd1234 customer name is sajal sharma or customer id is 1234532 or policy id is abcd1234 customer name is tarun and policy id is abcd1234 customer name is tarun or policy id is abcd1234 customer name is omkar customer name is dhiraj nambiar