# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r".*at \w+\.[A-Z] \(.+\n([\s\S]+\n)*.*(\[as realHandler]|<anonymous>)"
test_str = ("Error\n"
" at Logger._s (/var/user/impl/lib/log.js:7:17)\n"
" at Logger.I (/var/user/impl/lib/log.js:26:22)\n"
" at getWxContext (/var/user/impl/route.js:136:7)\n"
" at route (/var/user/impl/route.js:19:13)\n"
" at EventHandler.exports.main [as realHandler] (/var/user/index.js:14:22)\n"
" at EventHandler.handle (/var/runtime/node8/bootstrap.js:401:28)\n"
" at invoke (/var/runtime/node8/bootstrap.js:204:22)\n"
" at Timeout.setTimeout [as _onTimeout] (/var/runtime/node8/bootstrap.js:133:9)\n"
" at ontimeout (timers.js:475:11)\n"
" at tryOnTimeout (timers.js:310:5)")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.