#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mXx)(?:^|,)" & @CRLF & _
"([^,\r\n]+)" & @CRLF & _
"\s*,[,\s]*" & @CRLF & _
"(?=\1 (?![A-Za-zА-ЯЁа-яё]) )"
Local $sString = "Центральный федеральный округ,Москва" & @CRLF & _
"Центральный федеральный округ Москва,Москва" & @CRLF & _
"Центральный федеральный округ,Москва,Москва" & @CRLF & _
"Центральный федеральный округ,Москва ,Москва" & @CRLF & _
"Центральный федеральный округ,Великий Устюг , Великий Устюг" & @CRLF & _
"Центральный федеральный округ,Великий Устюг,Великий Устюгов"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")