const regex = /^[a-zA-Z0-9!@#$%^&*()_+\-=\[\]{};':"\\|,.<>\/?\sÀ-ÿĀ-ſƀ-ɏḀ-ỿɐ-ʯ]*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-zA-Z0-9!@#$%^&*()_+\\-=\\[\\]{};\':"\\\\|,.<>\\\/?\\sÀ-ÿĀ-ſƀ-ɏḀ-ỿɐ-ʯ]*$', 'gm')
const str = `München, Germany
Göteborg, Sweden
Québec City, Canada
São Paulo, Brazil
Reykjavík, Iceland
İstanbul, Turkey
Marseille, France
Kraków, Poland
Córdoba, Spain
Zürich, Switzerland
Brno, Czech Republic
Ljubljana, Slovenia
Český Krumlov, Czech Republic
Tromsø, Norway
Görlitz, Germany
äöüÄÖÜßẞáéíóúàèìòùâêîôûÁÉÍÓÚÀÈÌÒÙÂÊÎÔÛãõñÑçÇ
ČčŠšŽžĎŇňŘřěĚŸİ磳ƵƷąćęłńśźżĄĆĘŁŃŚŹŻẞ
مرحبا بوينوس دياس
Brčko, Bosnia and Herzegovina
Görlitz, Germany
Québec City, Canada
Łódź, Poland
Reykjavík, Iceland
Gdańsk, Poland
Malmö, Sweden
České Budějovice, Czech Republic
Žilina, Slovakia
Barcelona, Spain
Göteborg, Sweden
Málaga, Spain
Bratislava, Slovakia
Kraków, Poland
Bordeaux, France
Köln (Cologne), Germany
Reykjavík, Iceland
Helsinki, Finland
Praha (Prague), Czech Republic
Lisboa (Lisbon), Portugal`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}