// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)^[a-zA-Z0-9!@#$%^&*()_+\-=\[\]{};':"\\|,.<>\/?\sÀ-ÿĀ-ſƀ-ɏḀ-ỿɐ-ʯ]*$"#).unwrap();
let string = "München, Germany
Göteborg, Sweden
Québec City, Canada
São Paulo, Brazil
Reykjavík, Iceland
İstanbul, Turkey
Marseille, France
Kraków, Poland
Córdoba, Spain
Zürich, Switzerland
Brno, Czech Republic
Ljubljana, Slovenia
Český Krumlov, Czech Republic
Tromsø, Norway
Görlitz, Germany
äöüÄÖÜßẞáéíóúàèìòùâêîôûÁÉÍÓÚÀÈÌÒÙÂÊÎÔÛãõñÑçÇ
ČčŠšŽžĎŇňŘřěĚŸİ磳ƵƷąćęłńśźżĄĆĘŁŃŚŹŻẞ
مرحبا بوينوس دياس
Brčko, Bosnia and Herzegovina
Görlitz, Germany
Québec City, Canada
Łódź, Poland
Reykjavík, Iceland
Gdańsk, Poland
Malmö, Sweden
České Budějovice, Czech Republic
Žilina, Slovakia
Barcelona, Spain
Göteborg, Sweden
Málaga, Spain
Bratislava, Slovakia
Kraków, Poland
Bordeaux, France
Köln (Cologne), Germany
Reykjavík, Iceland
Helsinki, Finland
Praha (Prague), Czech Republic
Lisboa (Lisbon), Portugal";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}