$re = '/(?:^|\G\h+)([^\s.]+)(\h(?1))?(\h(?1))?(\h(?1))?(\h(?1))?(\h(?1))?(\h(?1))?(\h(?1))?(\h(?1))?(\.)?/m';
$str = 'Omul se poate combina multor gandiri-cu ideile cu ajutorul povestilor clasice corespunzatoare FAPTELOR si sensului abstract.
';
$subst = "$7$3$9$2$5$8$6$4 $1$10";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;