package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\w+([\.-]?\w+)+@[\w.-]+([\.-]?\w+)(\.\w{2,3})+$`)
var str = `babar.ali.shah-512_me.you_ir-getme@gmail-here-there.where_any.resource_avavi.com`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}