use strict;
my $str = '^(([^<>()[\\]\\\\.,;:\\s@\\"]+(\\.[^<>()[\\]\\\\.,;:\\s@\\"]+)*)|(\\".+\\"))@((\\[[0-9]{1,3}\\.[0-9]{1,3}\\.[0-9]{1,3}\\.[0-9]{1,3}])|(([a-zA-Z\\-0-9]+\\.)+[a-zA-Z]{2,}))$';
my $regex = qr/((?<!\\)(?:\\\\)*\[(?:\\.|[^\]\[])*)\[/p;
my $subst = '$1\\\\[';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";